Focus op Veiligheid

WPA2 is lek, waardoor aanvallers de encryptie van de WiFi-standaard kunnen breken. Een wakkere Nederlandse burger vroeg aan Mozilla om de certificaatautoriteit van de Nederlandse Staat niet meer te vertrouwen. De Linux-kernel werd met enkele lokale root exploits geconfronteerd. Deze en andere beveiligingsnieuwtjes lees je in “Focus op veiligheid”.

 

KRACK! WPA2 is lek

Beveiligingsonderzoeker Mathy Vanhoef van de KU Leuven zette de wereld op z’n kop met zijn publicatie van de Key Reinstallation Attack (KRACK). Het gaat om een beveiligingslek in de WPA2-encryptiestandaard voor WiFi, dat alle mogelijke toestellen treft: routers, smartphones, laptops, etc. En het is ook nog eens onafhankelijk van het besturingssysteem, want de fout zit in het protocol zelf.

De fout gebeurt in de handshake in het WPA2-protocol tussen een client (bijvoorbeeld je smartphone of laptop) en een draadloos toegangspunt, waarmee het apparaat wil verbinden. Die handshake dient als bevestiging dat beide toestellen over het juiste wachtwoord beschikken. Maar bij de handshake onderhandelen client en toegangspunt ook over de keuze van een encryptiesleutel, waarmee al het netwerkverkeer daarna wordt versleuteld. Vanhoef ontdekte dat het mogelijk is om een client een al gebruikte encryptiesleutel te laten inzetten voor alle verdere encryptie.

In Android en Linux is de aanval nog efficiënter, omdat beide besturingssystemen te forceren zijn om een sleutel met alleen maar nullen te gebruiken. Het programma wpa_supplicant 2.4 en hoger verwijdert de encryptiesleutel na installatie immers uit het geheugen door die te overschrijven met nullen, maar installeert door de KRACK-aanval die nulsleutel, waardoor een aanvaller vanaf dat moment eenvoudig al het verkeer dat het toestel uitstuurt, kan onderscheppen. De KRACK-aanval moet dan uiteraard nog gecombineerd worden met een Man-in-the-Middle-aanval.

Om van het lek misbruik te maken, dient de aanvaller zich binnen het bereik van je WiFi-netwerk te bevinden. Maar dat is relatief: in het verleden zijn onderzoekers er al in geslaagd om met speciale antennes tot twee kilometer ver verbinding met een WiFi-netwerk te maken.

Vanhoef had ruim voor zijn publicatie de belangrijkste fabrikanten op de hoogte gebracht van de fout, dus de kans is groot dat je ondertussen al een update hebt gekregen. Maar als je nog oudere toestellen in huis hebt draaien, die niet meer ondersteund zijn door de fabrikant, blijven ze kwetsbaar. Gaat het om een router of draadloos toegangspunt? Dan is dat niet zo'n probleem, omdat de fout alleen in clients uit te buiten is. Maar krijgt je Android-telefoon geen updates meer van de fabrikant, dan blijf je kwetsbaar en kun je beter een alternatieve Android-firmware installeren zoals LineageOS, die langer updates voorziet.

www.krackattacks.com

 

Local root exploit in Linux-kernel

Soms leveren oude bugs jaren later nog eens problemen op. In 2015 ontdekte Google ingenieur Michael Davidson een fout in het laden van PIE-binary's (Position-Independent Executables), met mogelijke geheugencorruptie als gevolg. De fout werd gefixt in Linux 4.0, maar de kernel-ontwikkelaars herkenden ze niet als een beveiligingsfout.

Beveiligingsbedrijf Qualys ontdekte onlangs een manier om de fout uit te buiten. Ze slaagden erin om de ld.so-linker een bibliotheek te laten laden en uit te voeren. Een gewone gebruiker krijgt daarmee rootrechten.

Aangezien de fout al twee jaar geleden is gepatcht, heb je op een up-to-date Linux-computer met moderne kernel niets te vrezen. Maar in enterprise Linux-distributies draaien nog heel wat oudere LTS-kernels. Aangezien de fout niet de status van beveiligingsfout kreeg, werd de patch niet gebackport naar die kernels. Qualys ontdekte dat alle versies van CentOS 7 vóór versie 1708 (13 september 2017), alle versies van Red Hat Enterprise Linux 7 vóór 7.4 (1 augustus 2017) en alle versies van CentOS 6 en Red Hat Enterprise Linux 6 uit te buiten zijn. Ondertussen zijn de kwetsbare distributies gepatcht.

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000253

 

Vertrouwt Mozilla certificaatautoriteit Nederlandse Staat niet meer?

Op de bugtracker van Mozilla maakte Cris van Pelt een ticket aan met de vraag om het vertrouwen in de rootcertificaat-autoriteit “Staat der Nederlanden” in te trekken. Cris argumenteert in zijn ticket dat de certificaatautoriteit net als de AIVD onder het Ministerie van Binnenlandse Zaken valt. Hij verwijst naar de nieuwe Wet op de inlichtingen- en veiligheidsdiensten, die de AIVD vanaf 1 januari 2018 expliciet de bevoegdheid geeft om met valse sleutels in systemen binnen te dringen.

In het ticket vroeg Mozilla opheldering aan Mark Janssen van Logius, het departement van het Ministerie van Binnenlandse Zaken, dat de certificaatautoriteit beheert. Mark beklemtoonde dat er allerlei checks & balances in werking zijn, waardoor de Nederlandse staat niet zomaar valse certificaten kan introduceren met de bedoeling om de inlichtingendienst te helpen. Zo gebeurt er jaarlijks een onafhankelijke audit en zijn er ook technische maatregelen genomen, die misbruik tegengaan. Tijdens de redactiesluiting was er nog geen officieel antwoord van Mozilla.

https://bugzilla.mozilla.org/show_bug.cgi?id=1408647

 

Bug in ALSA geeft aanvaller roottoegang

Advanced Linux Sound Architecture (ALSA), het audiosubsysteem van de Linux-kernel, kreeg te maken met een kritieke beveiligingsfout. Het ging om een zogenoemde use-after-free geheugenfout in de ALSA-sequencer interface. Bij deze fout geeft het programma een stuk geheugen vrij na gebruik, maar gebruikt dit daarna opnieuw. Hierdoor voert het programma in het beste geval ongedefinieerde code uit en crasht dus. In het slechtste geval voer je een speciaal geprepareerde code van een aanvaller uit, die daarmee roottoegang tot de computer verkrijgt.

De fout, CVE-2017-15265, liet een ingelogde gebruiker of kwaadaardige software die met normale gebruikersrechten draait, inderdaad toe om rootrechten op de machine te verkrijgen. De noodzaak om lokale toegang te hebben, vermindert weliswaar de kans op een succesvolle exploit, maar de mogelijkheid om roottoegang te verkrijgen, maakt de fout dan weer ernstig. De kernelontwikkelaars hebben de fout opgelost in Linux 4.13.4-2.

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15265

 

OpenSSH 7.6 trekt beveiliging op

OpenSSH 7.6 verwijdert de ondersteuning van SSH-protocol versie 1 in de client, inclusief de bijbehorende configuratieopties en documentatie. De client biedt standaard ook geen CBC-encryptie meer aan. Zowel de client als de server ondersteunen geen hmac-ripemd160 MAC meer en geen symmetrische encryptie via arcfour, blowfish en CAST. RSA-sleutels, die kleiner dan 1024 bits zijn, worden niet meer aanvaard. De optie StrictHostKeyChecking heeft nu een nieuwe mogelijke waarde: "accept-new". Daarmee accepteert de ssh-client automatisch een host key die ze nog niet zag, maar weigert ze een verbinding voor gewijzigde of ongeldige host keys.

www.openssh.com/txt/release-7.6

 

En verder

Google vond een aantal beveiligingsfouten in dnsmasq. Deze software wordt vaak in routers en IoT-apparaten, maar ook in desktop Linux-distributies, ingezet voor DNS, DHCP, router advertisements en network boot. Het ging om 3 potentiële remote code executions, 1 informatielek en 3 denial-of-service kwetsbaarheden. De fouten zijn opgelost in dnsmasq 2.78. NetBSD is aan het experimenteren met kernel address space layout randomization (KASLR). Die beveiligingsfunctie, die de Linux-kernel sinds versie 4.12 heeft, laadt bij elke opstart de kernel op een willekeurige locatie. Dit maakt het moeilijker om kwetsbaarheden in de kernel uit te buiten.

OpenBSD 6.2 heeft talloze nieuwe drivers, vooral voor de ARM-architectuur. Het installatieprogramma zorgt nu dat OpenBSD onmiddellijk tijdens de eerste opstart al naar beveiligingsupdates zoekt. OpenBSD 6.2 bevat OpenSSH 7.6, OpenSMTPD 6.0.0 en LibreSSL 2.6.3. CAINE 9.0 heeft heel wat nieuwe en opgewaardeerde programma's voor forensisch onderzoek en schakelt de SSH-server nu standaard uit. Tails 3.2 heeft Linux-kernel 4.12, ondersteunt PPPoE en inbelverbindingen en heeft Thunderbird een upgrade naar versie 52.3 gegeven. En in de Tor-browser zat een bug, die in sommige gevallen het echte IP-adres van Linux- en macOS-gebruikers lekte.

NEDLINUX FORUM

Het nederlandse linuxforum
Voor beginners en pro’s

 

 

 

 

E-mailadres



 

 

Nieuwste editie:

Linuxmag op Facebook

@linuxmagnl op Twitter

linuxmagNL Met de Raspberry Pi Zero W verscheen dit jaar een goedkope kleine variant van de Raspberry Pi mét wifi. Je kunt hie… https://t.co/YKAEHvwmoF
5hreplyretweetfavorite
linuxmagNL Niemand kent alle opties van alle commandline tools uit het hoofd. Het is belangrijker om te weten waar je de juist… https://t.co/4DwEhHOKBX
linuxmagNL Package management is één van de sterke punten van Linux in vergelijking met Windows en macOS. Linux Mint bevat eig… https://t.co/pLxEVxktdp